پچ امنیتی آسیب‌پذیری ۱۰ ساله سودو منتشر شد

پچ امنیتی آسیب‌پذیری ۱۰ ساله سودو منتشر شد

به‌تازگی برای آسیب‌پذیری امنیتی ۱۰ ساله‌ی ابزار سودو در سیستم‌عامل لینوکس، پچ امنیتی منتشر شده است.

امروز برای آسیب‌پذیری عمده سودو (Sudo) که اکثر اکوسیستم لینوکس را تحت تأثیر قرار می‌داد، پچ امنیتی منتشر شد. سودو ابزاری است که به ادمین‌ها اجازه می‌دهد به‌صورت محدود دسترسی روت در اختیار بعضی از کاربران قرار بدهند.

این آسیب‌پذیری که شناسه CVE-2021-3156 را دریافت کرده اما بیشتر به Baron Samedit معروف است، دو هفته پیش توسط شرکت امنیتی کوالیس (Qualys) کشف و امروز با انتشار پچ امنیتی Sudo v1.9.5p2 اصلاح شد.

طبق گزارش Zdnet، تیم سودو به‌تازگی توضیح مختصر و ساده‌ای درباره‌ی این مشکل امنیتی ارائه کرده است. براساس گفته‌های آنان، مهاجم می‌تواند از باگ Baron Samedit برای رسیدن به دسترسی روت استفاده کند. حتی اگر فرد سودجو در حال استفاده  از یک حساب کم‌امتیاز باشد که در فهرست /etc/sudoers نیست، باز هم این عملیات با موفقیت انجام می‌شود.

طی دو سال گذشته، دو نقص امنیتی دیگر نیز در سودو وجود داشته است؛ اما باگی که امروز رفع شد از همه‌ی موارد خطرناک‌تر بود. استفاده از دو آسیب‌پذیری قبلی، یعنی CVE-2019-14287 (معروف به -1 UID bug) و CVE-2019-18634 (معروف به pwfeedback) به دلیل نیاز به تنظیمات پیچیده و غیر استاندارد، کار ساده‌ای نبود.

اما در مورد باگ آخر، بسیاری از گزینه‌ها متفاوت است. به گفته‌ی کوالیس، این مشکل می‌تواند در سودو، هر جایی که فایل sudoers وجود دارد، تأثیر بگذارد. نکته قابل ‌توجه این است که فایل مذکور تقریبا در تمام نسخه‌های از پیش‌ نصب‌شده‌ی Linux+Sudo وجود دارد.

به گفته‌ی کوالیس، این باگ در جولای ۲۰۱۱ به کد سودو وارد شد و به‌طور مؤثری بر تمام نسخه‌های ده سال گذشته‌ی آن تأثیر گذاشته است. تیم کوالیس موفق به بررسی مستقل این آسیب‌پذیری و توسعه چندین مدل سوءاستفاده از آن در Ubuntu 20.04 (سودو 1.8.31)، Debian 10 (سودو 1.8.27) و Fedora 33 (سودو 1.9.2) شده‌ است.

کوالیس می‌گوید:

احتمالا سایر سیستم‌های ‌عامل‌ نیز قابل بهره‌برداری هستند.

در مجموع، آسیب‌پذیری Baron Samedit یکی از نادرترین مشکلات امنیتی سودو است که می‌تواند در دنیای واقعی مورد استفاده قرار بگیرد و افراد زیادی را درگیر کند. این باگ در مقایسه با دو اشکال قبلی که در سال‌های قبل کشف شده بودند، در سطح دیگری قرار دارد.

کوالیس به Zdnet گفت:

اگر اپراتورهای بات‌نت از طریق روش brute-force به حساب‌های سطح پایین فشار بیاورند، می‌توان از مرحله دوم این آسیب‌پذیری امنیتی در حمله استفاده کرد که باعث می‌شود سودجویان به‌راحتی دسترسی روت به‌دست بیاورند و کنترل کامل سرور هک‌شده را در دست بگیرند.

Zdnet دوشنبه گزارشی درباره‌ی این نوع ربات‌ها که از روش brute-force برای حلمه به سیستم‌های لینوکس استفاده می‌کنند منتشر کرد و در آن گفت استفاده از آ‌ن‌ها بسیار رایج شده است. هم‌اکنون برای دریافت پچ امنیتی که سودو را از شر سودجویان و غافلگیری‌های ناخواسته‌ راحت می‌کند، آن را به‌روزرسانی کنید.

نظر شما کاربران زومیت درباره وجود این باگ امنیتی خطرناک در سودو چیست؟ آیا ممکن است مشکلات دیگری از این دست در آن وجود داشته باشد که هنوز کشف نشده‌اند؟


منبع zdnet

از سراسر وب

  دیدگاه
کاراکتر باقی مانده

بیشتر بخوانید